#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\s:]+):(?:(\[)(?=[^][]*]))?((?(2)[^][]+|\S+))\]?"
Local $sString = "key1:value1 key#2:@value#2 nyet key3:[@value#3, value4] key4:[value5] :bar" & @CRLF & _
"" & @CRLF & _
"test:test[test] test:[test]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")