$re = '/([^\s:]+):(?:(\[)(?=[^][]*]))?((?(2)[^][]+|\S+))\]?/m';
$str = 'key1:value1 key#2:@value#2 nyet key3:[@value#3, value4] key4:[value5] :bar
test:test[test] test:[test]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);