import Foundation
let pattern = #"(\d{4})\/(\d{2})\/(.*)\.html"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)