package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Branch=(\S+)`)
var str = `Annotations: deployment.kubernetes.io/revision: 1
kubernetes.io/change-cause:
Branch=master-9eb8251 Message=Revert "ON-1796 Re-write the cart GET for edit cart (#1256)" (#1284)
This reverts commit 27e600f83ecd98923713e2996d0aeea0da2df8fa. Author=Gautam Prajapati Timestamp=2019-07-29T16:26:32.622777`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}