import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Branch=(\\S+)";
final String string = "Annotations: deployment.kubernetes.io/revision: 1\n"
+ " kubernetes.io/change-cause:\n"
+ " Branch=master-9eb8251 Message=Revert \"ON-1796 Re-write the cart GET for edit cart (#1256)\" (#1284)\n\n"
+ " This reverts commit 27e600f83ecd98923713e2996d0aeea0da2df8fa. Author=Gautam Prajapati Timestamp=2019-07-29T16:26:32.622777";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}