package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\S+(?:\s+\S+){2})\s+JURISDICTION\b`)
var str = `Kerala High Court Jurisdiction`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}