re = /(\S+(?:\s+\S+){2})\s+JURISDICTION\b/mi
str = 'Kerala High Court Jurisdiction'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end