package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]{1,2}\. [\w+()=#-]+ [\w+()=#-]+|[0-9]{1,2}\. [\w+()=#-]+`)
var str = `1. e4 Nf6 2. e5 Nd5 3. d4 d6 4. c4 Nb6 5. f4 dxe5 6. fxe5 Nc6 7. Be3 Bf5 8. Nc3 e6 9. Nf3 Qd7 10. Be2 O-O-O 11. O-O Be7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}