#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)=(\d+\.\d+)$"
Local $sString = "Болт с шест.гол. (DIN" & @CRLF & _
"933)" & @CRLF & _
" 0.111 х 5555.55=333.33" & @CRLF & _
"НДС 20% " & @CRLF & _
"ТОВАР " & @CRLF & _
"ПЕРЕДАЧА В КРЕДИТ " & @CRLF & _
"" & @CRLF & _
"КОД СТРАНЫ:555 " & @CRLF & _
"ДЕКЛАРАЦИЯ:111111/22222/33333" & @CRLF & _
"ЕД.ИЗМЕРЕНИЯ:тыс. шт " & @CRLF & _
"" & @CRLF & _
"Болт с шест.гол 2 (DIN" & @CRLF & _
"933)" & @CRLF & _
" 2.222 х 3333.33=7777.77" & @CRLF & _
"НДС 20% " & @CRLF & _
"ТОВАР " & @CRLF & _
"ПЕРЕДАЧА В КРЕДИТ " & @CRLF & _
"" & @CRLF & _
"КОД СТРАНЫ:555 " & @CRLF & _
"ДЕКЛАРАЦИЯ:111111/22222/33333" & @CRLF & _
"ЕД.ИЗМЕРЕНИЯ:тыс. шт"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")