const regex = /=(\d+\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=(\\d+\\.\\d+)$', 'gm')
const str = `Болт с шест.гол. (DIN
933)
0.111 х 5555.55=333.33
НДС 20%
ТОВАР
ПЕРЕДАЧА В КРЕДИТ
КОД СТРАНЫ:555
ДЕКЛАРАЦИЯ:111111/22222/33333
ЕД.ИЗМЕРЕНИЯ:тыс. шт
Болт с шест.гол 2 (DIN
933)
2.222 х 3333.33=7777.77
НДС 20%
ТОВАР
ПЕРЕДАЧА В КРЕДИТ
КОД СТРАНЫ:555
ДЕКЛАРАЦИЯ:111111/22222/33333
ЕД.ИЗМЕРЕНИЯ:тыс. шт`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}