using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{ *lang(?:ue)*[^\}']*''[^\}']*(?:[^\}']*''[^\}']*''[^\}']*)*\}\}";
string input = @"oui {{ langue |en|truc'' machin ''chose''}}
oui {{ langue |en|truc'' machin chose}}
oui {{lang| es |truc'' machin ''chose''}}
oui {{lang| es |truc'' machin ''chose'' ''bidule''}}
non {{lang| es |''truc'' machin ''chose''}}
non {{lien web|langue=es|''truc'' machin ''chose''}}
non ''{{lang| es |truc machin chose}}''";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}