import Foundation
let pattern = #"\{\{ *lang(?:ue)*[^\}']*''[^\}']*(?:[^\}']*''[^\}']*''[^\}']*)*\}\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
oui {{ langue |en|truc'' machin ''chose''}}
oui {{ langue |en|truc'' machin chose}}
oui {{lang| es |truc'' machin ''chose''}}
oui {{lang| es |truc'' machin ''chose'' ''bidule''}}
non {{lang| es |''truc'' machin ''chose''}}
non {{lien web|langue=es|''truc'' machin ''chose''}}
non ''{{lang| es |truc machin chose}}''
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)