import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?m)(?:[\\w]\\:|\\\\)(\\\\[a-z_\\-\\s0-9\\.]+)*(?=\\\\)";
final String string = "C:\\Users\\Mistura\\Desktop\\INITEST - Copy2\\In\\Bershka_555_v4.pdf.txt";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}