const regex = /(?i)(?m)(?:[\w]\:|\\)(\\[a-z_\-\s0-9\.]+)*(?=\\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?m)(?:[\\w]\\:|\\\\)(\\\\[a-z_\\-\\s0-9\\.]+)*(?=\\\\)', 'g')
const str = `C:\\Users\\Mistura\\Desktop\\INITEST - Copy2\\In\\Bershka_555_v4.pdf.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}