using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(\..+)+(?="")";
string input = @"[
{
""key1"": ""value"",
""key2"": {
""word1.word2.word3.word4.interestingPart"": {
""key1"": ""value"",
""key2"": ""value""
}
},
""key3"": ""value""
},
{
""key1"": ""value"",
""key2"": {
""word1.word2.word3.word4.word5.word6.thisIsAlsoAnInterestingPart"": {
""key1"": ""value"",
""key2"": ""value""
}
},
""key3"": ""value""
}
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}