import re
regex = re.compile(r".+(\..+)+(?=\")", flags=re.MULTILINE)
test_str = ("[\n"
" {\n"
" \"key1\": \"value\",\n"
" \"key2\": {\n"
" \"word1.word2.word3.word4.interestingPart\": {\n"
" \"key1\": \"value\",\n"
" \"key2\": \"value\"\n"
" }\n"
" },\n"
" \"key3\": \"value\"\n"
" },\n"
" {\n"
" \"key1\": \"value\",\n"
" \"key2\": {\n"
" \"word1.word2.word3.word4.word5.word6.thisIsAlsoAnInterestingPart\": {\n"
" \"key1\": \"value\",\n"
" \"key2\": \"value\"\n"
" }\n"
" },\n"
" \"key3\": \"value\"\n"
" }\n"
"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")