#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\n-\s.*(\n)[^-]"
Local $sString = "Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque" & @CRLF & _
"- red" & @CRLF & _
"- green" & @CRLF & _
"- blue" & @CRLF & _
"Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque" & @CRLF & _
"ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis" & @CRLF & _
"- red" & @CRLF & _
"- green" & @CRLF & _
"- blue" & @CRLF & _
"bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")