# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n-\s.*(\n)[^-]"
test_str = ("Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
"- red\n"
"- green\n"
"- blue\n"
"Lorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque\n"
"ac adipiscing mauris ante class placerat per sem quisque phasellus sociosqu, mollis\n"
"- red\n"
"- green\n"
"- blue\n"
"bluorem ipsum et cras praesent mollis ullamcorper laoreet mauris imperdiet quisque")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.