package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'([^'\\]*(?:\\.[^'\\]*)*)'|\S+`)
var str = `hello 'hi' 'how are' you
hello 'hi' 'how\' are' you`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}