re = /'([^'\\]*(?:\\.[^'\\]*)*)'|\S+/m
str = 'hello \'hi\' \'how are\' you
hello \'hi\' \'how\\\' are\' you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end