package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^,]+enst.18[^,]+`)
var str = `abc|frame|gtk|enst.15|pc|hg|,abc|framex|gtk2|enst.59|pxc|h5g|,abc|frbx|hgk4|enst.18|pif|homg|
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}