re = /[^,]+enst.18[^,]+/m
str = 'abc|frame|gtk|enst.15|pc|hg|,abc|framex|gtk2|enst.59|pxc|h5g|,abc|frbx|hgk4|enst.18|pif|homg|
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end