package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)P(\d+([,\.]\d+)?Y)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?D)?(T(\d+([,\.]\d+)?H)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?S)?)?|P\d+([,\.]\d+?)W`)
var str = `P1Y
PT35M
P0.5Y
P4W`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}