using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?![ab]*?bb)[ab]+\b";
string input = @"abb , ababbb , bba ,bbbaa , bbb,bb
aaaa
abaaaaa
baaaa
aaab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}