$re = '/\b(?![ab]*?bb)[ab]+\b/m';
$str = 'abb , ababbb , bba ,bbbaa , bbb,bb
aaaa
abaaaaa
baaaa
aaab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);