$re = '/(?!<a[^>]*?>)Java(?![a-z])(?![^<]*?<\/a>)/m';
$str = 'Java <li>Javascript</li> <a href="">Some Java here</a> more java';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);