import re
regex = re.compile(r"(.+) (HC|PO|bbt|bty|bjx|prs|bag|gls|nst|resort|shs|cts|atm|bls|gls|jck|clp|fsh|glv|bck|blt|drs|sle|hts|emn|ham|pre fall|str|pnt|skr|mat|m PO|bks|m |PreFall|Resort|brd|LO|AR|sok|F |S )|.+", flags=re.MULTILINE)
test_str = ("London str F20 212.jpg London\n"
"Luisa Spagnoli bbt S22 048.jpg Luisa Spagnoli\n"
"Marco Rambaldi bjx S22 006.jpg Marco Rambaldi\n"
"Max Mara bag S22 002.jpg Max Mara")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")