import Foundation
let pattern = #"(.+) (HC|PO|bbt|bty|bjx|prs|bag|gls|nst|resort|shs|cts|atm|bls|gls|jck|clp|fsh|glv|bck|blt|drs|sle|hts|emn|ham|pre fall|str|pnt|skr|mat|m PO|bks|m |PreFall|Resort|brd|LO|AR|sok|F |S )|.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
London str F20 212.jpg London
Luisa Spagnoli bbt S22 048.jpg Luisa Spagnoli
Marco Rambaldi bjx S22 006.jpg Marco Rambaldi
Max Mara bag S22 002.jpg Max Mara
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)