import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S*)(?: \\1)*(?:(?: (\\S*))(?: \\1| \\2)*(?: (\\S*))?)?(?: \\1| \\2| \\3)*$";
final String string = "lorum\n"
+ "lorum ipsum\n"
+ "lorum ipsum dolor\n"
+ "lorem lorem ipsum dolor ipsum ipsum\n"
+ "lorem lorem ipsum\n"
+ "lorem lorem <=>\n"
+ "1 2 3\n\n"
+ "lorem ipsum dolor sit lorum\n"
+ "lorem ipsum dolor sit\n"
+ "1 2 3 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}