$re = '/^(\S*)(?: \1)*(?:(?: (\S*))(?: \1| \2)*(?: (\S*))?)?(?: \1| \2| \3)*$/m';
$str = 'lorum
lorum ipsum
lorum ipsum dolor
lorem lorem ipsum dolor ipsum ipsum
lorem lorem ipsum
lorem lorem <=>
1 2 3
lorem ipsum dolor sit lorum
lorem ipsum dolor sit
1 2 3 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);