package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[^[]*?\]`)
var str = `[In ea consequunt et volor rec]eru[m]et latr?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}