$re = '/^\[[^[]*?\]/m';
$str = '[In ea consequunt et volor rec]eru[m]et latr?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);