#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<=from|join|table|into|exists|update) (?!IF)(\w+\.*)+"
Local $sString = "SELECT * FROM COLLECTIONNAME.SCHEMANAME.TABLENAME LEFT JOIN SCHEMANAME.TABLENAME ON A.D = B.D" & @CRLF & _
"" & @CRLF & _
"CREATE TABLE IF NOT EXISTS SCHEMANAME.NEWTABLENAME, SCHEMANAME.NEWTABLENAME" & @CRLF & _
"" & @CRLF & _
"ALTER TABLE SCHEMANAME.EXISTINGTABLENAME" & @CRLF & _
"" & @CRLF & _
"CREATE TABLE table_name (column_1 datatype, column_2 datatype, column_3 datatype);" & @CRLF & _
"" & @CRLF & _
"DELETE FROM table_name WHERE some_column = some_value;" & @CRLF & _
"" & @CRLF & _
"INSERT INTO table_name (column_1, column_2, column_3) VALUES (value_1, 'value_2', value_3);" & @CRLF & _
"" & @CRLF & _
"select * from A join (select top 5 * from B) on B.ID = A.ID where A.ID in (select ID from C where C.DOB = A.DOB)" & @CRLF & _
"" & @CRLF & _
"Select distinct W.WORKER_ID, W.FIRST_NAME, W.Salary " & @CRLF & _
"from Table1 W, Table2 W1 " & @CRLF & _
"where W.Salary = W1.Salary " & @CRLF & _
"and W.WORKER_ID != W1.WORKER_ID;" & @CRLF & _
"" & @CRLF & _
"left "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")