import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=from|join|table|into|exists|update) (?!IF)(\\w+\\.*)+";
final String string = "SELECT * FROM COLLECTIONNAME.SCHEMANAME.TABLENAME LEFT JOIN SCHEMANAME.TABLENAME ON A.D = B.D\n\n"
+ "CREATE TABLE IF NOT EXISTS SCHEMANAME.NEWTABLENAME, SCHEMANAME.NEWTABLENAME\n\n"
+ "ALTER TABLE SCHEMANAME.EXISTINGTABLENAME\n\n"
+ "CREATE TABLE table_name (column_1 datatype, column_2 datatype, column_3 datatype);\n\n"
+ "DELETE FROM table_name WHERE some_column = some_value;\n\n"
+ "INSERT INTO table_name (column_1, column_2, column_3) VALUES (value_1, 'value_2', value_3);\n\n"
+ "select * from A join (select top 5 * from B) on B.ID = A.ID where A.ID in (select ID from C where C.DOB = A.DOB)\n\n"
+ "Select distinct W.WORKER_ID, W.FIRST_NAME, W.Salary \n"
+ "from Table1 W, Table2 W1 \n"
+ "where W.Salary = W1.Salary \n"
+ "and W.WORKER_ID != W1.WORKER_ID;\n\n"
+ "left ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}