package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z][A-Za-z\s]+[a-z]`)
var str = `
Mostly Cloudy
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}