package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9.]`)
var str = `13.0
23.0
23
24,0
13A0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}