import re
regex = re.compile(r"^(([A-Z]{2}-\d{2}-(\d|[A-Z]){2})|(\d{2}-(\d{2}-[A-Z]{2}|[A-Z]{2}-\d{2})))$", flags=re.MULTILINE)
test_str = ("AA-00-00\n"
"00-00-AA\n"
"00-AA-00\n"
"AA-00-AA\n"
"AAA-00-AA\n"
"AA-AA-00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")