$re = '/^(([A-Z]{2}-\d{2}-(\d{2}|[A-Z]{2}))|(\d{2}-(\d{2}-[A-Z]{2}|[A-Z]{2}-\d{2})))$/m';
$str = 'AA-00-00
00-00-AA
00-AA-00
AA-00-AA
AA-00-A2
AAA-00-AA
AA-AA-00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);