$re = '/^(\S+|\S+\s+\d+\s+\S+) (\S+ )?sshd\[\d+\]: Failed password for (invalid user |illegal user )?(\S*) from (\S+)( port \S+ \S+\s*)?/';
$str = 'May 23 16:57:33 nostalgia-for-infinity sshd[8541]: Failed password for invalid user root from 8.8.8.8 port 123 ssh2 from 127.0.0.1 port 50594 ssh2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);