#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([(\w|N°|#|.\s]+\d+)"
Local $sString = "Colón N° 346 (Entre 21 de Mayo y Sotomayor)" & @CRLF & _
"Diego Portales Nº2291" & @CRLF & _
"Av. Pedro Aguirre Cerda N° 1010" & @CRLF & _
"Tarapaca N° 729" & @CRLF & _
"Local 3 A 1er. Piso, Centro de Convenciones Zofri" & @CRLF & _
"Av. Héroes de la Concepción Nº 2653 " & @CRLF & _
"Cerro Esmeralda 3130" & @CRLF & _
"Mall Calama, Balmaceda N° 3242 Local S-08" & @CRLF & _
"Av. Chorrillos # 1759 Local 1082 Exterior Jumbo" & @CRLF & _
"Av. Balmaceda N° 2355 Local BS - 121 / Subterráneo sector servicios" & @CRLF & _
"Av. Balmaceda N° 2337 - Local 2" & @CRLF & _
"Angamos N° 610 (Interior Universidad)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")