#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+?)(?:\.\[(\d{4}\s|\d{4}\-\d{4}\s|\d{4}\-\s|\d{4})?([^\]]*)\])?(?:\.(.+))?" & @CRLF & _
""
Local $sString = "Azertyuiop £££.[2024].Mini-série" & @CRLF & _
"Azertyuiop - qsdfghjklm.[2021-2023 Netflix].Manga" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")