$re = '/(.+?)(?:\.\[(\d{4}\s|\d{4}\-\d{4}\s|\d{4}\-\s|\d{4})?([^\]]*)\])?(?:\.(.+))?
/m';
$str = 'Azertyuiop £££.[2024].Mini-série
Azertyuiop - qsdfghjklm.[2021-2023 Netflix].Manga
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);