package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sip:(.*)@`)
var str = `Diversion: <sip:5100@10.10.10.10>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}