$re = '/sip:(.*)@/m';
$str = 'Diversion: <sip:5100@10.10.10.10>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);