package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\/p><br\s?\/?>`)
var str = `<p>my text 1</p><br /> some other content<br /> <p>some other paragraph followed by an html line break</p><br><br /> etc...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}