re = /<\/p><br\s?\/?>/m
str = '<p>my text 1</p><br /> some other content<br /> <p>some other paragraph followed by an html line break</p><br><br /> etc...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end