import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:[^A-Za-z\\r\\n]*[A-Za-z]){4})(?=(?:[^0-9\\r\\n]*[0-9]){7})[A-Za-z0-9]+$";
final String string = "ABCD1234567\n"
+ "123ABC456D7\n"
+ "12A34B56C7D\n\n\n"
+ "ABCD123456\n"
+ "12ABC456D7\n"
+ "1234B56C7D\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}