$re = '/^(?=(?:[^A-Za-z\r\n]*[A-Za-z]){4})(?=(?:[^0-9\r\n]*[0-9]){7})[A-Za-z0-9]+$/m';
$str = 'ABCD1234567
123ABC456D7
12A34B56C7D
ABCD123456
12ABC456D7
1234B56C7D
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);