#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<unit_type>SFE)(?P<unit_size>100|80|63|50|40|32|25)(?P<mounting_type>P|Z)(?P<decompression_feature>0)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/)(?P<seal_material>M)(?P<additional_details>(.|[0-9])*)$"
Local $sString = "SFE50Z0-1X/M" & @CRLF & _
"SFE32P0-1X/M" & @CRLF & _
"SFE32Z0-1X/M" & @CRLF & _
"SFE25Z0-1X/M" & @CRLF & _
"SFE50P0-1X/M" & @CRLF & _
"SFE40P0-1X/M" & @CRLF & _
"SFE63P0-1X/M" & @CRLF & _
"SFE63Z0-1X/M" & @CRLF & _
"SFE80Z0-1X/M" & @CRLF & _
"SFE40Z0-1X/M" & @CRLF & _
"SFE25P0-1X/M" & @CRLF & _
"SFE100Z0-1X/M" & @CRLF & _
"SFE80P0-1X/M" & @CRLF & _
"SFE100P0-1X/M" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")