import re
regex = re.compile(r"^(?P<unit_type>SFE)(?P<unit_size>100|80|63|50|40|32|25)(?P<mounting_type>P|Z)(?P<decompression_feature>0)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/)(?P<seal_material>M)(?P<additional_details>(.|[0-9])*)$", flags=re.MULTILINE)
test_str = ("SFE50Z0-1X/M\n"
"SFE32P0-1X/M\n"
"SFE32Z0-1X/M\n"
"SFE25Z0-1X/M\n"
"SFE50P0-1X/M\n"
"SFE40P0-1X/M\n"
"SFE63P0-1X/M\n"
"SFE63Z0-1X/M\n"
"SFE80Z0-1X/M\n"
"SFE40Z0-1X/M\n"
"SFE25P0-1X/M\n"
"SFE100Z0-1X/M\n"
"SFE80P0-1X/M\n"
"SFE100P0-1X/M\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")